$re = '/^(?:[a-z]{2}\d-)?[a-z]{2}-[a-z]-/mi';
$str = 'qq8-qq-q-anything
qq-q-anything
888-q-anything
anything-qq-q-anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);