using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[a-z]{2}\d-)?[a-z]{2}-[a-z]-";
string input = @"qq8-qq-q-anything
qq-q-anything
888-q-anything
anything-qq-q-anything";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}