using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/\*.*Copyright.*\n \*/\n";
string input = @"/*
Copyright © 2019 Apple Inc. All rights reserved.
a sdf ja;sdfj
asdfijase
*/
/*
<samplecode>
<abstract>
PositionPlayerTests
</abstract>
</samplecode>
*/
this
this\
asdas
/*
Copyright © 2020 Apple Inc. All rights reserved.
See Source/LICENSE/LICENSE.txt for details
*/
asdf
asdf
ase
asdsf
";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}