import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*.*Copyright.*\\n \\*/\\n";
final String string = "/*\n"
+ " Copyright © 2019 Apple Inc. All rights reserved.\n"
+ " a sdf ja;sdfj\n"
+ " asdfijase\n"
+ " */\n"
+ "/*\n"
+ " <samplecode>\n"
+ " <abstract>\n"
+ " PositionPlayerTests\n"
+ " </abstract>\n"
+ " </samplecode>\n"
+ " */\n"
+ "this\n"
+ "this\\\n"
+ "asdas\n"
+ "/*\n"
+ " Copyright © 2020 Apple Inc. All rights reserved.\n"
+ " See Source/LICENSE/LICENSE.txt for details\n"
+ " */\n"
+ "asdf\n"
+ "asdf\n"
+ "ase\n"
+ "asdsf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}