package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)/\*.*Copyright.*\n \*/\n`)
var str = `/*
Copyright © 2019 Apple Inc. All rights reserved.
a sdf ja;sdfj
asdfijase
*/
/*
<samplecode>
<abstract>
PositionPlayerTests
</abstract>
</samplecode>
*/
this
this\
asdas
/*
Copyright © 2020 Apple Inc. All rights reserved.
See Source/LICENSE/LICENSE.txt for details
*/
asdf
asdf
ase
asdsf
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}