import re
regex = re.compile(r"/\*.*Copyright.*\n \*/\n", flags=re.DOTALL)
test_str = ("/*\n"
" Copyright © 2019 Apple Inc. All rights reserved.\n"
" a sdf ja;sdfj\n"
" asdfijase\n"
" */\n"
"/*\n"
" <samplecode>\n"
" <abstract>\n"
" PositionPlayerTests\n"
" </abstract>\n"
" </samplecode>\n"
" */\n"
"this\n"
"this\\\n"
"asdas\n"
"/*\n"
" Copyright © 2020 Apple Inc. All rights reserved.\n"
" See Source/LICENSE/LICENSE.txt for details\n"
" */\n"
"asdf\n"
"asdf\n"
"ase\n"
"asdsf\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")