#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?! )\b[A-Z ]+\b(?<! )"
Local $sString = " aBC ABC ABC ABC ABc ABC AbC ABc ABC dg" & @CRLF & _
"ABC ABC abc" & @CRLF & _
" ABC ABC abc" & @CRLF & _
"abc ABC abc ABC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")