re = /(?! )\b[A-Z ]+\b(?<! )/m
str = ' aBC ABC ABC ABC ABc ABC AbC ABc ABC dg
ABC ABC abc
ABC ABC abc
abc ABC abc ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end