using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?! )\b[A-Z ]+\b(?<! )";
string input = @" aBC ABC ABC ABC ABc ABC AbC ABc ABC dg
ABC ABC abc
ABC ABC abc
abc ABC abc ABC";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}