$re = '/(?! )\b[A-Z ]+\b(?<! )/ms';
$str = ' aBC ABC ABC ABC ABc ABC AbC ABc ABC dg
ABC ABC abc
ABC ABC abc
abc ABC abc ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);