import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?! )\\b[A-Z ]+\\b(?<! )";
final String string = " aBC ABC ABC ABC ABc ABC AbC ABc ABC dg\n"
+ "ABC ABC abc\n"
+ " ABC ABC abc\n"
+ "abc ABC abc ABC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}