import re
regex = re.compile(r"\/\*\*[\s\S]*?\*\/", flags=re.DOTALL)
test_str = ("\n\n"
"class CategoryController extends Controller\n"
"{\n"
" /**\n"
" * Display a listing of the resource.\n"
" *\n"
" * @return \\Illuminate\\Http\\Response\n"
" */\n"
" public function index()\n"
" {\n"
" //\n"
" }\n\n"
" /**\n"
" * Show the form for creating a new resource.\n"
" *\n"
" * @return \\Illuminate\\Http\\Response\n"
" */\n"
" public function create()")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)