const regex = /libc*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('libc*', 'gm')
const str = `libc
libd
libe`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);