use strict;
my $str = 'libc
libd
libe';
my $regex = qr/libc*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";