import re
regex = re.compile(r"libc*", flags=re.MULTILINE)
test_str = ("libc\n"
"libd\n"
"libe")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)