#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?:\w(?=\w+?(\w\2?+\b)))+?)(\w{1,2})\2\b"
Local $sString = "testing taptaptaptap wow ok abacus" & @CRLF & _
"" & @CRLF & _
"Excellent truly remarkable" & @CRLF & _
"" & @CRLF & _
"antidisestablishmentarianism"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")