re = /\b((?:\w(?=\w+?(\w\2?+\b)))+?)(\w{1,2})\2\b/
str = 'testing taptaptaptap wow ok abacus
Excellent truly remarkable
antidisestablishmentarianism'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end