$re = '/\b((?:\w(?=\w+?(\w\2?+\b)))+?)(\w{1,2})\2\b/';
$str = 'testing taptaptaptap wow ok abacus
Excellent truly remarkable
antidisestablishmentarianism';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);