using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:\w(?=\w+?(\w\2?+\b)))+?)(\w{1,2})\2\b";
string input = @"testing taptaptaptap wow ok abacus
Excellent truly remarkable
antidisestablishmentarianism";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}