import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:\\w(?=\\w+?(\\w\\2?+\\b)))+?)(\\w{1,2})\\2\\b";
final String string = "testing taptaptaptap wow ok abacus\n\n"
+ "Excellent truly remarkable\n\n"
+ "antidisestablishmentarianism";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}