using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(( ?)(https?:\/\/(www\.)?[a-z0-9]+-?([a-z0-9]+)?\.[a-z]{1,4}(\.[a-z]{1,4})?)(/(.+)*)?)";
string input = @"https://regex101.com
https://www.regex101.com
https://www.regex101.edu.net
https://www.regex-101.com/12ac31564
https://www.regex101.com/12315=58abav
https://www.regex101.com/1231/ac%axw
https://www.regex101.com/1231/ac%a://xw
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}