re = /(( ?)(https?:\/\/(www\.)?[a-z0-9]+-?([a-z0-9]+)?\.[a-z]{1,4}(\.[a-z]{1,4})?)(\/(.+)*)?)/mi
str = 'https://regex101.com
https://www.regex101.com
https://www.regex101.edu.net
https://www.regex-101.com/12ac31564
https://www.regex101.com/12315=58abav
https://www.regex101.com/1231/ac%axw
https://www.regex101.com/1231/ac%a://xw
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end