const regex = new RegExp('(( ?)(https?:\\/\\/(www\\.)?[a-z0-9]+-?([a-z0-9]+)?\\.[a-z]{1,4}(\\.[a-z]{1,4})?)(/(.+)*)?)', 'gmi')
const str = `https://regex101.com
https://www.regex101.com
https://www.regex101.edu.net
https://www.regex-101.com/12ac31564
https://www.regex101.com/12315=58abav
https://www.regex101.com/1231/ac%axw
https://www.regex101.com/1231/ac%a://xw
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}