use strict;
my $str = 'https://regex101.com
https://www.regex101.com
https://www.regex101.edu.net
https://www.regex-101.com/12ac31564
https://www.regex101.com/12315=58abav
https://www.regex101.com/1231/ac%axw
https://www.regex101.com/1231/ac%a://xw
';
my $regex = qr/(( ?)(https?:\/\/(www\.)?[a-z0-9]+-?([a-z0-9]+)?\.[a-z]{1,4}(\.[a-z]{1,4})?)(/(.+)*)?)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}