// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(( ?)(https?:\/\/(www\.)?[a-z0-9]+-?([a-z0-9]+)?\.[a-z]{1,4}(\.[a-z]{1,4})?)(/(.+)*)?)").unwrap();
let string = "https://regex101.com
https://www.regex101.com
https://www.regex101.edu.net
https://www.regex-101.com/12ac31564
https://www.regex101.com/12315=58abav
https://www.regex101.com/1231/ac%axw
https://www.regex101.com/1231/ac%a://xw
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}