#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([A-Z]{3})_Posted_GL_JE_([0-9]{4})-(0[1-9]|1[0-2])-\b(0[1-9]|[1-2][0-9]|3[0-1])\b(?:{\d+})?"
Local $sString = "YDM_Posted_GL_JE_2021-06-21{1}.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")