re = /\b([A-Z]{3})_Posted_GL_JE_([0-9]{4})-(0[1-9]|1[0-2])-\b(0[1-9]|[1-2][0-9]|3[0-1])\b(?:{\d+})?/m
str = 'YDM_Posted_GL_JE_2021-06-21{1}.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end