using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([A-Z]{3})_Posted_GL_JE_([0-9]{4})-(0[1-9]|1[0-2])-\b(0[1-9]|[1-2][0-9]|3[0-1])\b(?:{\d+})?";
string input = @"YDM_Posted_GL_JE_2021-06-21{1}.xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}