import Foundation
let pattern = #"\b([A-Z]{3})_Posted_GL_JE_([0-9]{4})-(0[1-9]|1[0-2])-\b(0[1-9]|[1-2][0-9]|3[0-1])\b(?:{\d+})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"YDM_Posted_GL_JE_2021-06-21{1}.xml"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)