package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([A-Z]{3})_Posted_GL_JE_([0-9]{4})-(0[1-9]|1[0-2])-\b(0[1-9]|[1-2][0-9]|3[0-1])\b(?:{\d+})?`)
var str = `YDM_Posted_GL_JE_2021-06-21{1}.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}