using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)https?[^<>\s\'\""=]+(?:jpg|png|webp)\b|[^:<>\s\'\""=]+(?:jpg|png|webp)\b";
string input = @"img src=https://test.com/abc.jpg img src=test.com/abc.jpg background:../example/test.png <div> images/test.webp image.pnghellobackground-image: url('../images/pics/mobile/img.JPG')
""https://schema.org"",""dateModified"":""2022-12-29T09:3"":{""@type"":""ImageObject"",""url"":""i.dailymail.co.uk/1s/2022/12/29/09/aaa.jpg""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}