import Foundation
let pattern = #"(?i)https?[^<>\s\'\"=]+(?:jpg|png|webp)\b|[^:<>\s\'\"=]+(?:jpg|png|webp)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
img src=https://test.com/abc.jpg img src=test.com/abc.jpg background:../example/test.png <div> images/test.webp image.pnghellobackground-image: url('../images/pics/mobile/img.JPG')
"https://schema.org","dateModified":"2022-12-29T09:3":{"@type":"ImageObject","url":"i.dailymail.co.uk/1s/2022/12/29/09/aaa.jpg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)