import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)https?[^<>\\s\\'\\\"=]+(?:jpg|png|webp)\\b|[^:<>\\s\\'\\\"=]+(?:jpg|png|webp)\\b";
final String string = "img src=https://test.com/abc.jpg img src=test.com/abc.jpg background:../example/test.png <div> images/test.webp image.pnghellobackground-image: url('../images/pics/mobile/img.JPG')\n"
+ "\"https://schema.org\",\"dateModified\":\"2022-12-29T09:3\":{\"@type\":\"ImageObject\",\"url\":\"i.dailymail.co.uk/1s/2022/12/29/09/aaa.jpg\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}