# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)https?[^<>\s\'\"=]+(?:jpg|png|webp)\b|[^:<>\s\'\"=]+(?:jpg|png|webp)\b"
test_str = ("img src=https://test.com/abc.jpg img src=test.com/abc.jpg background:../example/test.png <div> images/test.webp image.pnghellobackground-image: url('../images/pics/mobile/img.JPG')\n"
"\"https://schema.org\",\"dateModified\":\"2022-12-29T09:3\":{\"@type\":\"ImageObject\",\"url\":\"i.dailymail.co.uk/1s/2022/12/29/09/aaa.jpg\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.