$re = '/(?i)https?[^<>\s\'\"=]+(?:jpg|png|webp)\b|[^:<>\s\'\"=]+(?:jpg|png|webp)\b/m';
$str = 'img src=https://test.com/abc.jpg img src=test.com/abc.jpg background:../example/test.png <div> images/test.webp image.pnghellobackground-image: url(\'../images/pics/mobile/img.JPG\')
"https://schema.org","dateModified":"2022-12-29T09:3":{"@type":"ImageObject","url":"i.dailymail.co.uk/1s/2022/12/29/09/aaa.jpg"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);