import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!00)(?!0+(?:[.,]\\d{1,2})?$)\\d{1,4}(?:[.,]\\d{1,2})?$";
final String string = "01\n"
+ " -> valid\n"
+ "00\n"
+ " -> not valid\n"
+ "0\n"
+ " -> not valid\n"
+ "1\n"
+ " -> valid\n"
+ "001\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}