re = /^(?!00)(?!0+(?:[.,]\d{1,2})?$)\d{1,4}(?:[.,]\d{1,2})?$/m
str = '01
-> valid
00
-> not valid
0
-> not valid
1
-> valid
001
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end