const regex = /^(?!00)(?!0+(?:[.,]\d{1,2})?$)\d{1,4}(?:[.,]\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!00)(?!0+(?:[.,]\\d{1,2})?$)\\d{1,4}(?:[.,]\\d{1,2})?$', 'gm')
const str = `01
-> valid
00
-> not valid
0
-> not valid
1
-> valid
001
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}