import re
regex = re.compile(r"^(?!00)(?!0+(?:[.,]\d{1,2})?$)\d{1,4}(?:[.,]\d{1,2})?$", flags=re.MULTILINE)
test_str = ("01\n"
" -> valid\n"
"00\n"
" -> not valid\n"
"0\n"
" -> not valid\n"
"1\n"
" -> valid\n"
"001\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")