using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Z]+)(?:\d+)?(?:[A-Z]+)?(?:\d+)?(?:\*\*)?\s";
string input = @"WDAA Öl
WDAA374 Öl
WDAA374FFD Öl
WDAA374FFD 3/2 Öl
WDDA LED Öl
DSD MMT3 k";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}