$re = '/^(?:[A-Z]+)(?:\d+)?(?:[A-Z]+)?(?:\d+)?(?:\*\*)?\s/m';
$str = 'WDAA Öl
WDAA374 Öl
WDAA374FFD Öl
WDAA374FFD 3/2 Öl
WDDA LED Öl
DSD MMT3 k';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);