const regex = /^(?:[A-Z]+)(?:\d+)?(?:[A-Z]+)?(?:\d+)?(?:\*\*)?\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Z]+)(?:\\d+)?(?:[A-Z]+)?(?:\\d+)?(?:\\*\\*)?\\s', 'gm')
const str = `WDAA Öl
WDAA374 Öl
WDAA374FFD Öl
WDAA374FFD 3/2 Öl
WDDA LED Öl
DSD MMT3 k`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}