import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z]+)(?:\\d+)?(?:[A-Z]+)?(?:\\d+)?(?:\\*\\*)?\\s";
final String string = "WDAA Öl\n"
+ "WDAA374 Öl\n"
+ "WDAA374FFD Öl\n"
+ "WDAA374FFD 3/2 Öl\n"
+ "WDDA LED Öl\n"
+ "DSD MMT3 k";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}