re = /^(?:[A-Z]+)(?:\d+)?(?:[A-Z]+)?(?:\d+)?(?:\*\*)?\s/m
str = 'WDAA Öl
WDAA374 Öl
WDAA374FFD Öl
WDAA374FFD 3/2 Öl
WDDA LED Öl
DSD MMT3 k'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end