#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)```(.*)```"
Local $sString = "head of file" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"code" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"docs text" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"code2" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"end of file"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")