re = /```(.*)```/
str = 'head of file
```
code
```
docs text
```
code2
```
end of file'
# Print the match result
str.match(re) do |match|
puts match.to_s
end