package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)```(.*)````)
var str = `head of file
\`\`\`
code
\`\`\`
docs text
\`\`\`
code2
\`\`\`
end of file`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}