using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"```(.*)```";
string input = @"head of file
```
code
```
docs text
```
code2
```
end of file";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}