$re = '/```(.*)```/s';
$str = 'head of file
```
code
```
docs text
```
code2
```
end of file';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);