#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never"
Local $sString = "GigabitEthernet0/2 is down, line protocol is down (notconnect) " & @CRLF & _
" Last input never, output never, output hang never" & @CRLF & _
"GigabitEthernet0/3 is down, line protocol is down (notconnect) " & @CRLF & _
"GigabitEthernet0/4 is down, line protocol is down (notconnect) " & @CRLF & _
" Last input 23w0d, output 23w0d, output hang never" & @CRLF & _
"GigabitEthernet0/5 is down, line protocol is down (notconnect) " & @CRLF & _
" Last input 23w0d, output 23w0d, output hang never" & @CRLF & _
"GigabitEthernet0/6 is down, line protocol is down (notconnect) " & @CRLF & _
" Last input 11w5d, output 1w4d, output hang never" & @CRLF & _
" Last input 11w5d, output 00:00:01, output hang never" & @CRLF & _
" Last input never, output never, output hang never" & @CRLF & _
"GigabitEthernet0/12 is down, line protocol is down (notconnect) " & @CRLF & _
" Last input never, output never, output hang never" & @CRLF & _
"GigabitEthernet0/2 is administratively down, line protocol is down (disabled) " & @CRLF & _
" Last input never, output never, output hang never" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")